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MARPLOT search options 
 
There are two main search options in MARPLOT 
 

1. Arrow tool 
 

2. Search menu 
 
 
Using the Arrow tool to identify objects in a Vulnerable Zone – The easiest way to search 
for objects in a Vulnerable Zone is to use the search capabilities of the MARPLOT Arrow 
tool. 
 
Part 1 – set up your Arrow tool to draw a circle  
 

1. Select File> Preferences 
2. Select the Tools tab 
3. Set Arrow Tool to “circle (from center)” 
4. Click OK 

 
Part 2 – do search 
 

1. Place the Arrow tool on the point from which the chemical is being released 
2. Click and drag (holding down the mouse button) until the counter at the lower left 

of the MARPLOT frame reaches the radius of the VZ 
3.  In the “Select on Layers. . .” list, mark the layers you wish to search 
4. Click on “Select”  (This will highlight selected map objects within the VZ radius.) 

 
Part 3 – export list of objects to an ASCII file 
 

1. Select File>Export 
2. In the “Export” dialog box, click on “selected objects” and “Marplot Simple Point 

Format” 
3. Click on the “Fields” button and select the fields you want to export (object name 

and layer name are best) 
4. Click OK 
5. Click the “Export” button 
6. Name your file 

 
The ASCII text file created this way identifies all of the objects you searched for within 
the VZ. 
 
Using The MARPLOT Search Menu to identify objects in a Vulnerable Zone - This time 
of year, a lot of you are just completing your hazard analyses for Title III compliance.  
One of the most frustrating aspects of this is the task of documenting what Special 
Locations are inside the VZ.  I don't have a panacea for you but here's a way to cut 
down on the workload a bit. 
 

  
 
http://www.CAMEOSupport.com 1 ©Regulations/Resources 

  



MARPLOT Tip Book  11/13/2003 
 

Part 1 - set up a search 
 
1.  Select the Facility whose Vulnerable Zone you wish to search 
2.  Click on the Facility's icon so that it is highlighted 
3.  Select List > Search 
4.  In the "Search for Objects" field, select "that are within. . ." 
5.  Next, enter the radius of the Vulnerable Zone 
6.  Lastly, in the "Layer(s) to search" filed, select "Individual layer"  and the name of the 
layer you plan to search, e.g., "CAMEO Day Care Centers." 
7.  Click on the search button to execute the Search.  (This will identify all  the objects on 
the layer.) 
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Figure 1. Set the Search Parameters for Your Vulnerable Zone. 
 

ou have your search collection, you need to save it. 

 saving a search collection 

e you've run your search collection, click on the "Save Collection" button 
ct a file name and location to store your search collection file. 

k save 
eat the processes in Steps 1 and 2 for as many search collections as you wish to 
.  You can recall them later to view or export them.  Keeping a list of search 

ons is a good idea. 

 You can search multiple layers at once and save the collection but the collection 
 be in order.  This approach is slower but it keeps all of the objects of a type, like 
e centers, together.) 
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Figure 2. Name and File Your Search Collection. 

ere's the time saver:  exporting your search collection to a file you can pull up in 
nother program. 

xporting a Search Collection to an ASCII File 

.  Select the Search collection you wish to export: 
- Select "Show Search Collection" on the List pull-down menu 
- Click on the "Load Search Collection" button 
- Select the named search collection you wish to export 
- Click on the "Open" button 

.  Select "Export" on the File pull-down menu 

.  In the Export dialog box, choose the following settings: 
Export - Search collection 
Format - MARPLOT Simple Point Format 

.  Click on the "Fields" button 

.  In the "Simple Text Export Fields" dialog box, remove checkmarks from all fields 
xcept object name and layer name. 
. Click OK to save your fields selection and return to the Export dialog box 
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7.  Click on the "Export" button 
8.  Assign a file name and location directory to your export file. 
 
(Note:  Export files are ASCII text files and can be opened by a wide variety of outside 
applications, such as word processing or spreadsheet programs.)  
 

 
Figure 3.  Export Your Search Collection. 

 
 
A file exported in this way can be imported into another application, e.g. a spreadsheet 
program for editing and printing.  In addition to the object name and layer name, the file 
will contain the latitude and longitude of the object.   
 
 
Identifying Facilities that are not Linked to MARPLOT  
 
If you have a lot of records in your CAMEO databases, you may have lost track of which 
ones are linked to your MARPLOT map. 
 
Other than going through CAMEO record-by-record and testing the links with the "Show 
on map" option, there really isn't a reliable way to verify that objects have been linked to 
the map.  However, there is an easy way to come close.  Here's how: 
 
You can identify Facilities that are not linked to the MARPLOT map by creating and 
exporting a search collection as shown above with the following exception:  In Part 1, 
use "Search for objects with any name" and the layer name corresponding to the 
database you wish to check, e.g., CAMEO Facilities.  This will return the names of all of 
the objects on the layer, i.e., everything that has been linked. 
 

  
 
http://www.CAMEOSupport.com 4 ©Regulations/Resources 

  



MARPLOT Tip Book  11/13/2003 
 

By following the steps in the previous section, you prepare and save a search collection.  
The only additional thing you need to do is can open the Search Collection file and print 
the contents.  Compare the facilities listed in this document with those shown in the 
CAMEO Facilities module.  Any facility that is not on the list from MARPLOT has not 
been linked to the map.   
 
 
Creating special layers with Import/Export 
 
Lets say you want to make a stripped-down version of the MARPLOT Roads layer 
showing only the streets that comprised a pre-planned evacuation route.  You could 
create a new map layer carefully trace over the streets that the evacuation route would 
follow or you could use this simple technique to get a precise layout of the route: 

 
- The first step is to create an equivalent, temporary layer (call it 

temp_roads, for example) 
- Set the display characteristics of the new layer to a contrasting color so 

you can tell them apart 
- Open both layers (Roads and roads_temp) 
- Select the objects on the Roads layer and move them to the roads_temp 

layer 
- When you have everything you want on the new layer, export it to an MIE 

file 
- Move all the objects from roads_temp back to the Roads layer and lock it 
- Delete roads_temp 
- Import the MIE file (this will re-create the roads_temp layer with only the 

feaqtures you want 
- Rename roads_temp 
 

This gives you all of the roads you want in their correct positions.  You 
can edit the display characteristics to give the objects on the layer the 
look you want. 

 
Inserting Bitmap Images 
Here is a way to add local features to your MARPLOT map. Check the “Insert picture 
object” option on the Edit pull-down menu. This feature allows you to insert a Windows 
bitmap image into your MARPLOT map and assign scale to the image. That means that 
the picture will shrink or grow as you zoom in or out on your map. It becomes part of the 
map you see on the screen.  

I am not going to spell out the steps for adding a picture object; it would take entirely too 
much space. Besides, the use of picture objects is described very well in Section 5.5 in 
your MARPLOT User Guide.  

Here is an example of how you can use this feature. Suppose there is a new subdivision 
that has been constructed in your community. You have a scanned image file of the 
subdivision and want to add it to your map. There are two options open to you. You can 
add the image and use it “as is” as part of your map or you can use it as a template to 
add objects to your “real” map layers.  
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Option 1. The simplest way to use a bitmap image in MARPLOT is to insert it as a 
picture object and use it as though it were part of the map. To do this, you first must 
make a layer for your picture object. Next, insert your object in the proper place on the 
map as described in your MARPLOT manual.  

To ensure that the picture winds up in the right place, you need to have two reference 
points that are common to the bitmap image and to your MARPLOT map. You need to 
give MARPLOT the coordinates of one point and either the distance to the second or the 
coordinates of the second. These might be two intersections or two sets of 
latitudinal/longitudinal coordinates. Or, you also can use the distance from one point to 
another.  

By default, the new layer will be placed at the top of your layer list. Map layers are 
displayed in the order in which they appear on the layer list, so the object you have 
inserted will appear on top of other map features. This can be awkward if the picture 
object covers up map features that you want to see. To avoid this, move the picture layer 
to the bottom of your layer list. All you have to do is highlight the layer on the layer list, 
click the “Move” button and select “bottom.” If the picture layer is at the bottom of the 
layer list, all of the other layers will be displayed on top of it. That means you can use the 
bitmap image as a backdrop for other mapping activities. (See Figure 4.)  

 

Figure 4. Two reference points are needed for geo-referencing. 

 

Option 2. Your second option is to enter the bitmap image, as in Option 1, and use it as 
a template for adding new MARPLOT map objects. In other words, you can trace over 
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the features and add features like roads to MARPLOT map layers. Instructions for 
editing roads can be found in Section 5.4 of your MARPLOT manual. (See Figure 5.) 

  

Figure 5. Move the bitmap layer to the bottom of the layer list. 

 

Next, hide the bitmap image and view the result. To do this, go to the layer list (on the 
List pull-down menu) and put a check mark in the Hide column next to the layer with 
your bitmap image.  
 
Options for Saving MARPLOT Screen Images 
 
Experienced MARPLOT users often develop detailed information displays on their maps.  
Scenario-specific map displays of things like Vulnerable Zone analyses can convey a lot 
of information but can also take a long time to set up.  Making them in advance and 
storing them in MARPLOT layers can save time but can also increase map clutter.  
Saving bitmap images using the “Save as Picture” option on the File pull-down menu is 
no solution.  The images cannot be recovered and edited when changes occur.   
 
Here’s a way to save information in MARPLOT for later recall and modification. 
 
Create a new layer for the MARPLOT map objects you plan to create - This tip involves 
use of the MARPLOT Import/Export option to save data.  At the end of the process, you 
will export all of the objects on this layer. 
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Starting from the main MARPLOT screen:  
− Select “Layer List” on the List pull-down menu 
− Click on the “New” button 
− Enter the name of your new layer, e.g. “Green Valley Chlorine VZ” 
− Set your layer’s display characteristics (optional) 
− Save and return to the main MARPLOT screen 
− Draw your scenario-specific objects and annotations 

 

Figure 6. Draw your scenario-specific objects and annotations. 
 

− Use “Save as Picture” on the File pull-down menu to create a bitmap 
image (optional) 

− Save your work 
 
 
Use the Search and Export functions to save all of the objects on your scenario-specific 
layer – Exporting all of the objects on the  
 
With your new layer displayed search for and export the objects you want to save: 
 

− Select “Search” on the List pull-down menu 
− Set up a search for “Objects with any name” on you new layer 
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Figure 7. Set up a search for “Objects with any name” on you new layer. 
 
− Execute the search 
− When the found set is appears, select “Show all on map”  (all objects will be 

highlighted) 
− Select “Export” on the File pull-down menu 
− Choose “Selected objects” and MARPLOT Import/Export (MIE) 

 

Figure 8. Choose “Selected objects” and MARPLOT Import/Export (MIE). 
 

− Click on the “Export” button 
− Assign an appropriate name to your export file, e.g., Green Valley VZ.mie 
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Now that you have exported all of the objects on your layer, you can delete the layer 
itself.  The layer can be recreated at any time by re-importing the file. 
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